PXE / TFTP funktioniert nicht

LB_Muenchen
Beiträge: 2
Registriert: Fr Feb 01, 2019 11:47 am

PXE / TFTP funktioniert nicht

Beitragvon LB_Muenchen » Fr Feb 01, 2019 12:11 pm

Hallo,

ich hoffe ich habe nur einen kleinen Denk/Konfigfehler:

im ACMP habe ich ein Boot-Image und ein OS hinterlegt, die entsprechenden Treiber etc. zur Verfügung gestellt, Antwort-Dateien erstellt und Rollout-Templates erzeugt.
Der PXE-Dienst ist aktiv und an Port 69/UDP gebunden, Firewall Inbound auch offen. DHCP-Optionen 66+67 auf dem DHCP-Server gesetzt. (IP des ACMP-Servers und pxeboot.n12)

Startet nun ein Client ins PXE-Boot bekommt er sauber eine DHCP-Adresse zugewiesen und versucht per TFTP das File zu laden ... hier fliegt er aber nach dem ersten "Punkt" (Anzeige: TFTP. ) "raus" und meldet

PXE-M0F: Exiting Intel Boot Agent ...

Wo habe ich da was vergessen ß

Besten Dank im Voraus schon einmal,

Markus

Dennis Koch
Beiträge: 167
Registriert: Di Nov 20, 2012 4:03 pm

Re: PXE / TFTP funktioniert nicht

Beitragvon Dennis Koch » Fr Feb 01, 2019 12:19 pm

Hallo Markus,

prinzipiell ist es nicht nötig die DHCP Optionen zu setzen, da der NBS auf den Ports lauscht und diese Informationen dann mitsendet.
Zumindest die Option 67 ist auch problematisch da der BootFileName dynamisch von ACMP generiert wird. Daher sollte diese Konfiguration erstmal wieder entfernt werde und testen ob das ggf. schon die Lösung ist.
Mit freundlichen Grüßen / Best regards

Dennis Koch
Aagon GmbH

LB_Muenchen
Beiträge: 2
Registriert: Fr Feb 01, 2019 11:47 am

Re: PXE / TFTP funktioniert nicht

Beitragvon LB_Muenchen » Fr Feb 01, 2019 1:18 pm

Servus Dennis,

vielen Dank für die schnelle Antwort.

Leider habe ich folgendes Verhalten (alle Varianten einzeln durchgespielt):0

Option 66 gesetzt, 67 entfernt: keine DHCP-Zuweisung, no boot filename received
Option 66 und 67 entfernt: keine DHCP-Zuweisung, no boot filename received
Option 66 gesetzt, 67 "leer": DHCP wird zugewiesen, no boot filename received
Option 66 gesetzt, 67 "beliebig": DHCP wird zugewiesen, no boot filename received (wobei ich beliebig für einen vorhandenen Filenamen z.B. pxeboot.n12 setze)

Nachtrag: der DHCP ist ein eigener Windows-DHCP im gleichen Subnetz wie der ACMP-Server und der Client !

Liebe Grüße aus München,

Markus

Dennis Koch
Beiträge: 167
Registriert: Di Nov 20, 2012 4:03 pm

Re: PXE / TFTP funktioniert nicht

Beitragvon Dennis Koch » Fr Feb 01, 2019 5:02 pm

Hallo Markus,

ich würde Sie bitten sich einmal sich mit unseren Support in Verbindung zu setzen da es diverse Ursachen für dieses Problem gibt.
DHCP Optionen schließe ich als Ursache erst einmal aus. Diese muss man nur setzen wenn der Network Boot Service auf dem DHCP Server läuft. Hier dann aber auch nur die Option 60 und 66.

Mögliche Ursachen:
- Rollout wurde nicht gestartet
- FileRepo wurde dem Network Boot Service nicht zugewiesen
- Network Boot Service ist nicht korrekt konfiguriert
- Broadcast vom PXE kommt am NBS nicht an
...

Mit dem Support kann man aber anhand der Server-, NetworkBootService und/oder Wiresharklogs verfolgen wo der Fehler ist.

Kontaktinformationen:
https://www.aagon.de/service-a-support.html
Mit freundlichen Grüßen / Best regards

Dennis Koch
Aagon GmbH

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast