MSI vs. SETUP

cmg
Beiträge: 37
Registriert: Fr Mai 02, 2014 2:09 pm

MSI vs. SETUP

Beitragvon cmg » Do Feb 05, 2015 3:08 pm

Hallo,

Ich habe immer wieder mal das Problem/Phänomen, dass installierte Software in ACMP (in der Abfrageverwaltung) sowohl im Bereich MSI, als auch unter SETUP auftaucht. Das ist eigentlich kein Problem, aber nun habe ich gesehen, dass eine Software (Citavi, Literaturverwaltung) nach dem Update von Version 4.4 auf 4.5 in den beiden Bereichen mit unterschiedlichen Versionsnummern angezeigt wird :roll: : unter SETUP wird die Version 4.4 angezeigt, unter MSI die 4.5!

Mich würde nun interessieren, WOHER ACMP diese Daten hat, da ich mich auf einem betroffenen Rechner angemeldet habe und zumindest in der registry keinen Hinweis auf die Version 4.4 mehr finden konnte ...

Und: Stehe ich da allein mit diesem Phänomen oder kennt das hier auch jemand und wenn ja, wie wird damit umgegangen?

Vielen Dank,
Christian

FBiehn
Beiträge: 55
Registriert: Do Apr 22, 2010 10:38 am

Re: MSI vs. SETUP

Beitragvon FBiehn » Do Feb 05, 2015 3:25 pm

Also MSI wird mit Sicherheit von Windows direkt ausgelesen und "normale" Setup Software, soweit ich weiß, aus dem Bereich der Registry, wo auch die Uninstall Pfade drin stehen. Das müsste unter HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ sein (ggf WoW6432).

cmg
Beiträge: 37
Registriert: Fr Mai 02, 2014 2:09 pm

Re: MSI vs. SETUP

Beitragvon cmg » Do Feb 05, 2015 4:42 pm

OK, aber die SETUP-Version 4.4 ist eben nirgends in der registry zu finden ... und wenn ich das Programm starte, sehe ich dass die Version 4.5 installiert ist :?

cmg
Beiträge: 37
Registriert: Fr Mai 02, 2014 2:09 pm

Re: MSI vs. SETUP

Beitragvon cmg » Mi Mai 13, 2015 12:29 pm

Update:

Ich habe dasselbe Problem heute auch mit dem Adobe Reader!
Installiert wird die MSI-Version "XI" und dabei auch jeweils die aktuelle Patch-Version. Heute kam der Patch "11.0.11" heraus und ich habe diesen einfach wieder in mein Installationsskript eingebunden. Dieses läuft auch durch, aber danach sehe ich in der Abfrageverwaltung auf dem Client im Bereich "Setup" die 11.0.11, unter "MSI" aber noch die Version 11.0.10!
Auf dem Client ist die neueste Version drauf und auch wenn ich in der registry schaue, sehe ich die 11.0.11 -also woher kommt diese falsche Angabe???

Dennis Koch
Beiträge: 91
Registriert: Di Nov 20, 2012 4:03 pm

Re: MSI vs. SETUP

Beitragvon Dennis Koch » Mi Mai 13, 2015 1:32 pm

Hallo Christian,

momentan entsprechen die Installer u.a. von Adobe nicht dem Microsoft-Standard, da diese sich entgegen der Richtlinien nicht im primären Unterscheidungskriterium unterscheiden (Vgl. http://msdn.microsoft.com/de-de/library/aa370860.aspx : "No two nonidentical .msi files should ever have the same package code."). Damit in Zukunft ACMP auch Pakete, die nicht diesem Standard folgen, korrekt inventarisiert werden können, wurde in der Vergangenheit bereits ein entsprechender Vorgang innerhalb unseres Bugtrackers angelegt, dem Sie als betroffenen Kunden zur Erhöhung der Priorität hinzugefügt wurden.

Je nachdem von welchen Rechner die Softwaredaten zuletzt in die Datenbank eingetragen werden kann es auch in den Clientdetails zu einer falschen Information kommen.
Wenn ein Client mit einer älteren Version seine Daten liefert überschreibt diese Version die aktuellere weil derzeit in der Datenbank die Unterscheidung gem. Microsoft Standard durchgeführt wird.
Mit freundlichen Grüßen / Best regards

Dennis Koch
Aagon GmbH

cmg
Beiträge: 37
Registriert: Fr Mai 02, 2014 2:09 pm

Re: MSI vs. SETUP

Beitragvon cmg » Mi Mai 13, 2015 3:59 pm

Hallo Herr Koch,

Danke für die Information!
Dann warte ich mal auf den Patch :wink:

Christian

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste